Can't see Genesis SEO settings

Homepage Community Forums Legacy Theme Support Can't see Genesis SEO settings

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #17441
    Danna McCormick

      Theme: Legacy

      This site was just launched yesterday. Yoast SEO has been installed by a previous developer. For a variety of reasons, I wanted to flip back over to Genesis SEO. Despite my best efforts listed below, I cannot get the Genesis > SEO settings to appear. The Genesis tech thinks its a plugin conflict, but I don’t think so. I’m just tossing this out to see if you have ever encountered this problem and if you were able to resolve it.

      Things I have tried:
      – deactivated, then deleted Yoast plugin
      – rename /plugins folder to turn off all plugins
      – reinstalled Genesis 2.2.6
      – activated the 2015 Theme, then reactivated Genesis Theme
      – went into phpMyAdmin… removed ALL lines in ALL tables that referenced Yoast

      Nothing will bring back my Genesis SEO Settings. I’m baffled.


        That’s the first time I’ve heard of that issue. I tried searching to see if others had this issue, but nothing came up.

        I just tested ( on this site) by deactivating the Yoast plugin, but the Genesis SEO settings showed up normally as they should, and everything seems to be working fine. I have no idea what’s going on with your site.

        On the page where the SEO settings are supposed to show, I did have to Open the “Tab” where they usually are….do you see a tab that’s unopened perhaps?

        Also, if you go to a Page Editor (for an example) click the “Screen Options” at the top of the screen and make sure the Theme SEO settings checkbox is checked to show –

        Double check again that Yoast is deactivated before attempting the above steps and see if that works. If it doesn’t then I have no idea what it could be. I actually just started using Yoast a week ago so I’m still learning it at the moment.

        Danna McCormick

          Wes, thanks for your response.

          Funny… this took 3 emails to Studio Press to figure it out, and I’m almost embarrassed at the simple solution.

          Go to Users > Your Profile in your site’s dashboard and be sure the box is checked to “Enable SEO Settings submenu.”

          So now you know.


            Ah! Yep, just what I figured! The same thing happens to us all, even the “Experts” lol. Glad you got it working! Let me know if you need anything!

          Viewing 4 posts - 1 through 4 (of 4 total)
          • The topic ‘Can't see Genesis SEO settings’ is closed to new replies.