Epik Doesn't Work With New WordPress

Homepage Community Forums Epik Theme Support Epik Doesn't Work With New WordPress

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #22970


      After troubleshooting with my web host it’s been narrowed down to the
      Epik theme.

      My websites are still up and running but there is something within
      the Epik code that isn’t compatible with the new WordPress.

      I can’t edit or create new posts. It goes to a blank page.

      We’ve done all the testing including plugins, etc. When switching to
      the Genesis parent theme everything goes back to normal.

      What is the fix within the Epik code for this?




        Hi Jeff,

        Epik should definitely work with the latest version of WordPress. It’s working perfectly fine on my end. I’ve been running the latest version of WordPress 5.0 and just tested again to make sure. I can create, and edit posts and pages with no problem.

        I don’t think there’s anything inside the Child theme that would prevent you from being able to create or edit posts. WordPress is usually responsible for that part. There isn’t any code in the theme that alters that functionality.

        I would suggest disabling all of your plugins to see if that’s where your issue is coming from. There are still a lot of plugins out there that cause conflicts with Gutenberg, so I would try disabling them to see which one it might be.

        Do you have custom code added in anywhere? Inside or outside your theme? I would check that as well.

        Other than that, try reinstalling WordPress from the Update page….and also make sure you have the latest updated version of the Genesis Framework. If you installed WordPress and there was an error in the install process, then it could cause an issue like that to happen. Double check all of those areas and let me know if you see a difference.


          Hi Jeff,

          I must concur with Wes that Epik works fine with gutenberg, the problem IMHO is that gutenberg is not ready to be consumed…

          Being a big fan of epik with a number of my sites running it with complicated code and webbadassery I became worried on seeing your post… SO i went to the web site of my FAVORITE client and immediately upgraded everything, plugins and all, to their latest versions (after i made a backup of course).

          It was immediately confusing and distressing like any new development environment is but I noticed that a lot of things I have come to depend on in the editor not only were not there but were inaccessable. Yuk. C’mon wordpress? I mean one of the MAIN reasons for wordpress’s continued success is the ease at which coders and designers can apply fancy schmancy details to an otherwise boring CMS based blog application… If i cant do that, i may as well go back to coding my own php or shtml (remember shtml?)…

          So my solution, since I figured I had mirrored your situation close enough for my comfort was to just disable the thing using a plugin made by the wordpress contributors…


          Push that gutenberg stuff out of the way and get back to work. They are gonna support the classic editor till 2022 so I think I will wait till 2020 before I try Gutenberg again. Once the bugs are worked out…



            Someone helped me find the issue.

            For some reason this code was breaking the themes ability to edit and create posts.

            Once I removed it everything worked.

            I originally had it in there to comply with all that GTMetrix stuff.

            add_action(‘customize_register’, ‘customizer’);
            function defer_parsing_of_js ( $url ) {
            if ( FALSE === strpos( $url, ‘.js’ ) ) return $url;
            if ( strpos( $url, ‘jquery.js’ ) ) return $url;
            return “$url’ defer “;
            add_filter( ‘clean_url’, ‘defer_parsing_of_js’, 11, 1 );


              Awesome! Glad everything is working now.

              Thanks for the update!

            Viewing 5 posts - 1 through 5 (of 5 total)
            • You must be logged in to reply to this topic.